Back to overview
Resolved

VOD under maintenance.

Jul 18, 2026 at 7:53pm UTC
Affected services
Alpha

Resolved
Jul 18, 2026 at 8:42pm UTC

Maintenance has concluded and VOD is in working order.

Created
Jul 18, 2026 at 7:53pm UTC

We are undergoing unexpected maintenance on our VOD (movies and series) section of the Alpha Playlist. We do not have an ETA but you will find the status update here when it's resolved.

Please select from the Omega Playlist to watch movies and series for the time being.

Thank you for your patience and understanding.